Why is the browser prompting me to install the scanning service repeatedly?

Scenario:

A user has already installed the Dynamsoft Service (DynamsoftServiceSetup) on the machine, but the browser still keeps prompting the user to download and install it.

Causes:

  1. The Dynamsoft Service is not installed properly.
  2. The Dynamsoft Service is installed correctly but not started.
  3. The requests sent to the Service are redirected because you are using a proxy server.
  4. The service's listening ports are blocked by another software, like an anti-virus software.
  5. The service is blocked by plugins you have installed in the browser. (e.g. NoScript)

Resolution:

  1. Check the path C:\Windows\SysWOW64\Dynamsoft\DynamsoftService and make sure you have files like DynamsoftService.exe and TWAINDSM.dll, etc.
  2. Check Windows Local Services and make sure Dynamsoft Service is listed and Running.
  3. Disable the proxy server to confirm it's the cause. Once confirmed, try to reconfigure the proxy to make sure it doesn't redirect requests sent to '127.0.0.1'
  4. Check your anti-virus software or any other software that can block local ports and make sure the ports 18622, 18623, 18625 and 18626 are not blocked.
  5. Disable all the plugins in the browser, refresh and try again.

If the above doesn't work, please feel free to contact us.

Scenario:

A user has already installed the DynamicWebTWAINHTML5Edition on the machine, but the browser still keeps prompting the user to download and install it.

IMPORTANT! If you are using Chrome v57+ or Firefox v53+, please check this article for a resolution.

NOTE: If the issue only occurs on IE 10/11 but not on Chrome or Firefox, please check the IE proxy setting.

Causes:

  1. The DynamicWebTWAINHTML5Edition is not installed properly.
  2. The local service for Dynamic Web TWAIN HTML5 Edition is not started.
  3. The service is blocked by another software, like an anti-virus software.

Resolution:

  1. Check the path C:\Windows\SysWOW64\Dynamsoft\DynamicWebTwain\ForChrome and make sure you have files like WebTWAINService.exe and TWAINDSM.dll, etc.
  2. Check Windows Local Services and make sure Dynamic WebTWAIN Service is listed and Running.
  3. Check your anti-virus software or any other software that can block local ports and make sure the ports 18618 and 18619 are not blocked.

If the above doesn't resolve the issue, to look further into the issue, we can use the DWTTestTool provided by Dynamsoft.

In order to use the tool to troubleshoot please follow the step-by-step guide below:

  1. Download DWTTestTool and run it locally
  2. Follow the instructions given by the tool and finish the test
  3. A \Report\ folder will be generated in the same directory of the tool
  4. Zip the whole \Report\ folder and send it to support[at]dynamsoft.com

Please give as many details as you can about the issue and any screenshots you can provide could help to pinpoint the issue.

Once our team checks all the information you provide, we will get back to you via email.


If you need any assistance or have any problem, please feel free to contact us.

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