Why Mozilla Firefox keeps asking me to install after upgrading to 30.0

After upgrading to Firefox 30.0, you would be asked to install the add-on over and over again even if it has been installed.

We have worked out a solution to fix this problem.

If you were using our JS files to initiate the control, please feel free to replace your files with following ones.

The initiate JS files are for trial version, if you are using full, please don't forget to update your version number, is-trial and product key as per your situation.

How to upgrade to full DWT?

If you didn't use our JS files, please refer to code snippets below. We highlight the changes we made in bold.

else {
    if (!_bInIE) {
        navigator.plugins.refresh(false);
        if (_iPluginLength != navigator.plugins.length) {
            for (var i = 0; i < navigator.mimeTypes.length; i++) {
                if (navigator.mimeTypes[i].type.toLowerCase().indexOf(_strMIMETYPE.toLowerCase()) > -1) {
                    location.reload();
                }
            }
        }
        for (var i = 0; i < navigator.mimeTypes.length; i++) {
            if (navigator.mimeTypes[i].type.toLowerCase().indexOf(_strMIMETYPE.toLowerCase()) > -1) {                
                    _vPluginExist = true;
                }
            }
        }
    }

        if (!_vPluginExist) {
            _noControl();
    }
}

Then, please click 'Activate Dynamic Web TWAIN' to run the control.


If you need any assistance or have any problem, please feel free to contact us.