How to upgrade ImageCapture Suite Plug-in to the latest version on the client side?

First, please make sure ImageCapture Suite (ICS) Plug-in has been upgraded to the latest version on the server side. More details

Then please follow the instructions on the scan page to download & install the new version of Plug-in.

If you installed ICS Plug-in on your machine before and didn't get prompt to update the plug-in automatically, please follow the steps in the article to remove old plug-in first. After that, you can access the scan page to install the new version.

For version 8 or older version user, please restart the browser after you updated the Plug-in.