Using SourceAnywhere with VS 2012/2015

SourceAnywhere (SAW) works well with Visual Studio 2012/2015. You can follow the steps below to integrate SAW in VS 2012/2015.

  1. Open an existing project or create a new one in VS 2012.
  2. Set SAW as the current source control provider at VS menu Tools->Options->Source Control.

  3. Add the solution into the source control of SAW. Right-click on the solution file in Solution Explorer and click Add Solution to Source Control.

  4. You will then be prompted to log in SAW Server.

  5. After you go through the steps to add the solution to SAW Server, you will see a lock icon beside the items in Solution Explorer which indicates it's under source control. And you can see the source control commands by right-click an item.

    You can also find the source control commands at menu File->Source Control.

  6. From now on, you can do Check Out, Check In, View History, Compare etc. on your VS 2012 project.