Error message: Error occured while writing Blowfish user key into database

Symptoms

When you try to import a Blowfish key, you may receive the following error message:

Cause

The possible cause is that the SourceAnywhere Standalone folder, which places the Blowfish_Key_DB.ini file, is missing at:

For Windows XP user
C:\Documents and Settings\{user name}\Application Data\Dynamsoft\SourceAnywhere Standalone

For Windows 7 user
C:\Users\{user name}\AppData\Roaming\Dynamsoft\SourceAnywhere Standalone

Resolution

You can log in SourceAnywhere Standalone Client using the unsecure port and the SourceAnywhere Standalone folder will be created automatically. Or you can create the folder manually. After that, you can try logging in using a secure port.

Also, the easier and more secure way is to use SSL. To enable SSL:

1. Set a port for SSL

2. Genaret a SSL Root Cert