Error: Login failed for user ‘NT AUTHORITYNETWORK SERVICE’.

Symptom:

When you log in ITA, you may receive the following error:

Error: Login failed for user 'NT AUTHORITYNETWORK SERVICE'.

Cause:

The identity of the application pool which ITA is using has no permission to access SQL Server.

This may occur when the ITA server is in a domain.

Resolution:

1. Create a new Windows user "itauser".

2. Add "itauser" to the IIS_WPG group.

3. Create a new application pool, with its .Net Framework version as v1.1 and Managed Pipeline Mode as Classic.

4. Configure the identity to the new user "itauser".

5. Add the new user to SQL Server (Security->Logins).

6. Set the ITA website to use the new application pool.