Error Message: The user name can not be empty

Symptom:

You may get the following error message when you import your Visual SourceSafe(VSS) database (VSS 6.0) to SourceAnywhere Standalone repository:

The user name can not be empty

Cause:

The cause of this problem is that your VSS database has been corrupted.

If the VSS database is corrupted, VSS API 6.0 may not be able to get some file histories when retrieving VSS project histories during importing. However, VSS API 8.0 doesn't have this issue. 

Resolution:

Please try running VSS Analyze tool to check and repair the VSS DB. Make sure to backup the VSS database before running the tool.

For information about how to find the "Analyze VSS DB" tool, please click here.

Also, you may upgrade to VSS 8.0 and try importing again. (It is recommended that you run the Analyze tool to repair your VSS database after upgrading, in case the corruption of VSS DB brings up other problems.)