Why do I need to install Dynamic Web TWAIN every time when I go back to the web page?

Symptom:
When you access Dynamic Web TWAIN related web page for the first time, you are asked to install the ActiveX control. The application works well after you install the control. But the Security Warning dialog box pops up every time when you go back to the web page. The application works fine after you click the Install button.

Cause:
The behavior occurs when the version number of Dynamic Web TWAIN you wrote in you web application does not coincide with the version you are using.

Resolution:
Modify the version number of Dynamic Web TWAIN in you code to coincide with the version you are using. If you are using the 9.1 version of Dynamic Web TWAIN, the code should be like follows:

<object classid="clsid:E7DA7F8D-27AB-4EE9-8FC0-3FEC9ECFE758" 
id="DynamicWebTwain1" 
width="250" height="350" codebase = "DynamicWebTwain.cab#version=9,1">
  ......
    <param name="VersionInfo" value="Dynamic Web TWAIN 9.1">
  ......
<object>

Note: In the code above, 9.1 is the version number of Dynamic Web TWAIN you are using.