Dynamic Web TWAIN Installation issues

This page is for

Note: This page is for customers who are using HTML5 Edition of Dynamic Web TWAIN on Chrome 57+, Firefox 53+.

Symptom:

Even after Dynamic Web TWAIN HTML5 Edition has installed properly and works on earlier versions of Chrome or Firefox, it doesn't work anymore on Chrome 57+ or Firefox 53+ and keep prompting you to download and install it again on a secure page (SSL).

Cause:

All versions before v12.3 use SHA-1 algorithm and commonName matching in certificates. In Chrome 57 or Firefox 53 has officially removed support for SHA-1 certificates. Furthermore, Chrome 58+ has removed the support for commonName matching in SSL certificates. More info can be found on

Chrome:
https://www.chromestatus.com/features/4981025180483584

https://security.googleblog.com/2016/11/sha-1-certificates-in-chrome.html

https://www.bleepingcomputer.com/news/software/google-chrome-57-released-with-webassembly-support-36-security-fixes/

Firefox:
https://blog.mozilla.org/security/2017/02/23/the-end-of-sha-1-on-the-public-web/

IE/Edge:
https://blogs.windows.com/msedgedev/2016/11/18/countdown-to-sha-1-deprecation/

Solution:

As SHA-1 certificate is indeed insecure and support for it will probably be permanently removed later on in Chrome, Firefox, Edge, etc. At the same time, the commonName matching deprecation will also make the old certificates invalid.

The recommended solution is to upgrade to v12.3+ of the SDK. If you are not the developer of the scanning application, please contact the application support team for the latest version.

Note: This page is for customers who are using HTML5 Edition of Dynamic Web TWAIN on IE 10/11.

Symptom:

Dynamic Web TWAIN HTML5 Edition could work fine with Chrome and Firefox. But on IE 10/11, the browser keeps prompting you to download and install DynamicWebTWAINHTML5Edition.

Cause:

  1. Dynamic Web TWAIN doesn't work with your IE proxy setting
  2. You are a domain user and the IP 127.0.0.1 is not considered local anymore

Possible solution 1:

Please navigate to Internet Explore -> Tools -> Internet Option -> Connections -> LAN settings, and uncheck the "Automatically detect settings" checkbox.

Possible solution 2:

Please navigate to Internet Explore -> Tools -> Internet Option -> Security tab ->  Local intranet -> Sites, and uncheck the "Include all sites that bypass the proxy server" checkbox.

If you need any assistance or have any problem, please feel free to contact us

Note: This page is for customers who are using ActiveX of Dynamic Web TWAIN on IE browser. Since version 11.0, HTML5 Edition is introduced to support IE 10/11 and Edge.

 

If you are trying to install the plug-in and it is not correctly installing please make sure that you are running Internet Explorer as an administrator.
To do this right-click Internet Explorer and click “Run as administrator”. This will allow you to install Dynamic Web TWAIN correctly.
If this is not the case please review the following:

Symptom:

When you access a web page containing Dynamsoft ActiveX control, you may see a red cross on the page.

Cause:

The related ActiveX control is not downloaded and installed on the client machine successfully.

Solution:

1. Check the security settings of IE on the client machine and verify the following security settings of IE to "Prompt" or "Enabled":

  1. Download signed ActiveX controls
  2. Run ActiveX Controls and plug-ins
  3. ActiveX controls marked safe for scripting
  4. Automatic Prompting for ActiveX Controls

The dialog box of the security setting can be launched from menu Tools < Internet Options. Then select the security tab.

2. If you are using Windows Vista/7/2008, please try turning off Protected Mode of IE.

3. The CAB file may be invalid. If you are not sure whether it’s valid, please send the CAB file to support[at]dynamsoft.com and we will check it for you.

4. Check if you have enabled the ActiveX Filtering. If so, turn it off from Tools < ActiveX Filtering or in the gear icon < safety.

5. The ActiveX control was already installed on the machine.
To check it, please go to IE menu Tools < Manage Add-ons, choose All add-ons in the drop-down list and see if you can find any DynamicWeb*** class in the add-on list. If you are able to see the add-on double click it to check the detailed info such as its location, the version etc.
If the control is already there, please clear them and try accessing the scan page again (How to remove Dynamsoft ActiveX).

If you need any assistance or have any problem, please feel free to contact us

Note: This page is for customers who are using HTML5 Edition of Dynamic Web TWAIN on macOS in Chrome/FF.

Symptom:

Even after Dynamic Web TWAIN HTML5 Edition has been installed properly, Chrome claims it's not installed and Firefox claims a new version is available.

Cause:

Dynamic Web TWAIN HTML5 edition communicates with the local service via IP 127.0.0.1 and this IP is not bypassed in the proxy configuration of your macOS.

Solution:

Add 127.0.0.1 to the proxy server bypass list.

Is this page helpful?

Leave a Reply

Your email address will not be published.